Skip to main content
UNPWNED
CVE Radar
HighRedis

CVE-2025-46817

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

CVSS Base Score
8.8

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploit Probability
90%EPSS PERCENTILE0100

More exploitable than 90% of all CVEs · Top 10%

Is your site exposed to this?

Run a free scan. UNPWNED fingerprints your stack and flags this CVE class if the affected technology is detected.

Check my site
Details
Published
2025-10-03
Last modified
2026-10-19
Affected
Redis

Data from the National Vulnerability Database (NVD), CISA KEV, and FIRST.org EPSS. This product uses the NVD API but is not endorsed or certified by the NVD. EPSS is a probability estimate, not a guarantee of exploitation.